在使用jQuery Validation插件时,一开始遇到的诡异问题是当浏览器调试(F12)时,如果文档模式使用的是IE7标准,则会出现以下错误:

SCRIPT3: 找不到成员。 jquery.js, 行2582 字符4

找到一篇CSDN的帖子:SCRIPT3:找不到成员,其中一位朋友的回答可以作为临时解决方案:

在jquery.validate.js中找到以下内容:

// Add novalidate tag if HTML5.
this.attr( "novalidate", "novalidate" );

把这行注释掉即可。IE9、10好像没有此问题。看来IE7要迟早要被淘汰了。

在使用jQuery Validation插件时还遇到一个问题,详见:jQuery Validation插件onfocosout/onkeyup出错的解决方法

转载请注明:摩登坊 » jQuery Validation 在IE7(兼容模式)下出现“找不到成员”的脚本错误

继续查看有关 的文章

1访客评论

  1. 这里应该是IE10下才有这个问题。原因是验证html5引起的。
    解决方案:给代码价格判断: if (typeof (Worker) !== “undefined”) { this.attr(‘novalidate’, ‘novalidate’); }

    leshem07-07 16:12

我来说说

*

*

取消